Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 29, 2026 - 16:30 UTC
Scheduled
In coordination with our upstream vendors, this window will be utilized to perform important capacity upgrades and apply security patches to network equipment. We will also be utilizing this window to perform general system maintenance to minimize the number of future disruptions. Total estimated outage is 2 windows of 10-15 minutes during the prescribed window. We apologize for any inconvenience this may cause.
Posted Aug 25, 2026 - 19:17 UTC
This scheduled maintenance affected: Shared Hosting (Windows Shared Hosting, Windows SQL Hosting, Linux Shared Hosting), E-Mail Services (Hosted E-Mail, CloudMail Premium E-Mail), and Dedicated Servers.