The issue has been resolved at this time. If you are experiencing any issues, please contact us at support@net10.net
Posted Apr 21, 2025 - 17:40 UTC
Identified
We have identified an issue caused by a recent Microsoft patch that is causing HTTP2 security errors including "inadequate_security" on our non-PCI Windows Web Servers. A fix has been identified and we are in the process of implementing it.
Posted Apr 21, 2025 - 17:28 UTC
This incident affected: Shared Hosting (Windows Shared Hosting).