Updated URL for Spam Filtering and Daily Digest Links

Incident Report for Net10 Internet Services

Monitoring

In order to mitigate an issue caused by several anti-virus products blocking all or part of our email security "Daily Digest" messages, the URL for the email security dashboard and the daily digest links has been updated. Unfortunately, this means that links in previously sent digests will no longer work and will require a login to access. (This login is the same as your email login & password.)

Going forward, you can expect to see the links in the daily digest message reference "emailsecurity.net10.net" instead of "spamfilter.net10.net" which we hope will resolve this issue permanently.

In the meantime, should you need to access your dashboard to release quarantined messages or update settings, you may browse to https://emailsecurity.net10.net/ and log in with your email address & password. We apologize for any inconvenience this may cause.
Posted Aug 13, 2025 - 16:57 UTC
This incident affects: E-Mail Services (GoSecure E-Mail Security).