Issues were related to a power distribution issue stemming from a major utility disruption and heavy lightning activity. A full evaluation of the environment is in process and a detailed report will be made available once the evaluation is complete. All systems are up and operational at this time and no further disruption is expected.
Posted Oct 14, 2025 - 00:02 UTC
Monitoring
The underlying issue has been resolved. We are currently monitoring systems and ensuring that all services have been restored. Another update will be posted shortly.
Posted Oct 13, 2025 - 20:58 UTC
Investigating
We are currently investigating the source of connectivity issues to the environment at our Phoenix datacenter. More updates will be posted as soon as possible.
Posted Oct 13, 2025 - 20:20 UTC
This incident affected: Shared Hosting (Windows Shared Hosting, Windows SQL Hosting, Linux Shared Hosting), E-Mail Services (Hosted E-Mail, CloudMail Premium E-Mail), and Dedicated Servers.