Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 02, 2025 - 04:00 UTC
Scheduled
During this window we will be performing maintenance and equipment installation in our network infrastructure/backbone. Additionally, some hypervisors will receive critical security patches during this time. As a result several 3-5 minute service interruptions can be expected during the maintenance window as traffic is rerouted and systems are rebooted.
Posted Apr 01, 2025 - 21:35 UTC
This scheduled maintenance affected: Shared Hosting (Windows Shared Hosting, Windows SQL Hosting, Linux Shared Hosting), E-Mail Services (Hosted E-Mail, CloudMail Premium E-Mail), and Dedicated Servers.