The scheduled maintenance has been completed. All services are operating normally at this time.
Posted Aug 17, 2025 - 06:58 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 17, 2025 - 05:00 UTC
Scheduled
During this maintenance window, network infrastructure including firewalls and switch stacks, will be undergoing upgrades. This will result in a temporary outage of approximately 15-20 minutes during the maintenance window.
Posted Aug 12, 2025 - 04:36 UTC
This scheduled maintenance affected: Shared Hosting (Windows Shared Hosting, Windows SQL Hosting, Linux Shared Hosting), E-Mail Services (Hosted E-Mail, CloudMail Premium E-Mail), and Dedicated Servers.