Mail is delivering normally at this time and we are considering the issue resolved. We will continue to monitor in case there are any further issues.
Posted Sep 25, 2024 - 01:36 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 25, 2024 - 01:35 UTC
Update
At this time email delivery is functional but delayed for most customer domains. We are continuing to monitor the issue and work with our vendor on resolution. The delays are improving, but not as fast as we would like them to be.
Posted Sep 24, 2024 - 22:52 UTC
Update
Mail delivery continues to be delayed for some customers. The condition is improving following the implementation of fixes at GoSecure and we expect everything to return to normal once all of the queued mail is processed.
Posted Sep 24, 2024 - 21:31 UTC
Monitoring
A fix has been implemented by GoSecure and we are seeing spooled email start to process and deliver. We will continue to monitor and provide additional updates.
Posted Sep 24, 2024 - 17:47 UTC
Identified
We are aware of an issue with the GoSecure email security platform that is causing delays of inbound and outbound messages. We are working with GoSecure to resolve the issue as quickly as possible.