All services operating normally at this time. Upon completion of investigation we will post an update with RFO.
Posted Sep 23, 2026 - 10:47 UTC
Monitoring
All services have recovered and are operating normally at this time. We are continuing to investigate the root cause and will report further once it is identified.
Posted Sep 23, 2026 - 09:47 UTC
Investigating
We are currently investigating a significant multiple-carrier outage at our Phoenix Datacenter. All services hosted out of our PHX facility are currently impacted. We will post more information as soon as it is available.
Posted Sep 23, 2026 - 09:38 UTC
This incident affected: Shared Hosting (Windows Shared Hosting, Windows SQL Hosting, Linux Shared Hosting), E-Mail Services (Hosted E-Mail, GoSecure E-Mail Security, CloudMail Premium E-Mail), and Dedicated Servers.